System requirements

  1. Overview
  2. ROS system requirements
  3. myAccount system requirements
  4. Local Property Tax (LPT) system requirements

Local Property Tax (LPT) system requirements

Operating system and browser versions supported

For the best experience with LPT online, we recommend that you use any of the following combinations, including later versions:

System requirements
TypeOperating SystemBrowser Versions
PC Windows XP Service Pack 3 FireFox 19+, IE7+, Chrome 23+
PC Windows Vista FireFox 19+, IE8+, Chrome 23+
PC Windows 7 FireFox 17+, IE8+, Chrome 23+
PC Windows 8 IE10+, Chrome 23+
MAC OS X 10.7 Lion Safari 6.0.2, FireFox 16, Chrome 23+
MAC OS X 10.8 Mountain Lion Safari 6.0.2, FireFox 16, Chrome 23+

Browser settings:

To use LPT online successfully you must have cookies enabled.

Ideally, you should also have JavaScript enabled for the best experience, though this is not absolutely necessary.

Other options:

We are aware that LPT online works on numerous other devices and browsers, including the iPAD and Android devices. However, we are currently unable to handle support requests for these platforms.